re = /iPhone; CPU ([^)]+) like Mac OS/i
str = '(iPhone; CPU iPhone OS 16_3 like Mac OS X'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end