$re = '/rfi (.*?) .*?(\((?:[^()]++|(?2))*\))/mi';
$str = 'New RFI 087 (Concrete Beam at Planter)
New RFI 087 (Concrete (Beam) at Planter)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);