#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)^([\w\W]+?)((?:\w+\.){0,}([^A-Za-zА-Яа-я_])h([^A-Za-zА-Яа-я_]))(?:\sAS \[[A-Za-zА-Яа-я_]+\]){0,}"
Local $sString = "SELECT `L`, " & @CRLF & _
"`r_e`, " & @CRLF & _
"T1.[r_w], " & @CRLF & _
"`Soi`, " & @CRLF & _
"`Sor`, " & @CRLF & _
"`Swc`, " & @CRLF & _
"`i_k_2`, " & @CRLF & _
"`mu_w`, " & @CRLF & _
"`mu_o`, `Газоконденсатный_фактор` AS [Газоконденсатный_фактор], `Газосодержание_нефти` AS [Газосодержание_нефти], " & @CRLF & _
"`Геологические_запасы_конденсата`, " & @CRLF & _
"`Геологические_запасы_нефти`, " & @CRLF & _
"`Геологические_запасы_свободного_газа`, " & @CRLF & _
"`D`, " & @CRLF & _
"`Извлекаемые_запасы_конденсата`, " & @CRLF & _
"`Извлекаемые_запасы_нефти_новых_скважин`, " & @CRLF & _
"`Извлекаемые_запасы_нефти`, " & @CRLF & _
"`КИН`, " & @CRLF & _
"`Количество_буровых`, " & @CRLF & _
"`Количество_скважин`, " & @CRLF & _
"`FracCount`, " & @CRLF & _
"`Fw`, " & @CRLF & _
"`F`, " & @CRLF & _
"`Коэффициент_компенсации`, " & @CRLF & _
"`phi`, " & @CRLF & _
"`Ef`, " & @CRLF & _
"`Объемный_коэффициент_воды`, " & @CRLF & _
"`Bo`, " & @CRLF & _
"`Период_строительства_скважины`, " & @CRLF & _
"`Плотность_воды`, " & @CRLF & _
"`ro_o`, " & @CRLF & _
"`Плотность_сетки_скважин`, " & @CRLF & _
"`Площадь_объекта`, " & @CRLF & _
"`k_h`, " & @CRLF & _
"`k_f`, " & @CRLF & _
"T1.`Pwf`, " & @CRLF & _
"`Psat`, " & @CRLF & _
"`c_w`, " & @CRLF & _
"`c_o`, " & @CRLF & _
"`c_r`, " & @CRLF & _
"`S`, " & @CRLF & _
"`Соотношение__доб_нагн__0___беск`, " & @CRLF & _
"`Стартовая_приемистость`, " & @CRLF & _
"`Стартовый_дебит_жидкости`, " & @CRLF & _
"`Стартовый_дебит_нефти`, " & @CRLF & _
"`m1`, " & @CRLF & _
"`m2`, " & @CRLF & _
"`Стоимость_скв__ГС+ГРП`, " & @CRLF & _
"`Стоимость_скв__ГС+МГРП`, " & @CRLF & _
"`Стоимость_скв__ГС`, " & @CRLF & _
"`Стоимость_скв__ННС+ГРП`, " & @CRLF & _
"`Стоимость`, " & @CRLF & _
"`Pi`, " & @CRLF & _
"`t_p`, " & @CRLF & _
"`Тип_заканчивания_доб_скв`, " & @CRLF & _
"`Тип_заканчивания_нагн__скв`, " & @CRLF & _
"`wf`, " & @CRLF & _
"T1.[h] FROM [DeleteMe5$A1:DM253]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1 Max($2) AS [Year]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)