#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9a-zA-Z]{10}.*([A-Z\s]{16,})\\n"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"4nXQOweFyC\x10HWANG SEAN SOJIN\n" & @CRLF & _
"^[0-9a-zA-Z]{10}\\[0-9a-z]{3}([A-Z\s]{3,})\\n" & @CRLF & _
"" & @CRLF & _
"^[0-9a-zA-Z]{10}\\x10([A-Z\s]{3,})\\n" & @CRLF & _
"" & @CRLF & _
"^[0-9a-zA-Z]{10}\\x14([A-Z\s]{3,})\n" & @CRLF & _
"" & @CRLF & _
"# 정의되어야 함" & @CRLF & _
"" & @CRLF & _
"4nYBfE4dug\x07GUO JIE\n" & @CRLF & _
"" & @CRLF & _
"4nYWf22CBO\x08LI FULAN\n" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^[0-9a-zA-Z]{10}\\x08([A-Z\s]{3,})\\n" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"4mfP1jNaF4\x14광진실리콘(주)\n" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"4nXckRULYB\x0fCHANG LAI HSIEN\n" & @CRLF & _
"" & @CRLF & _
"0UN97Wa9oU\t507030360A0130(\x010\x011\x011\x010\x0202\x011(\x010(\x010\x01N\x0b20년/20년\x082021031860860\x012\x011\x03B\x011\x01N\x0820210318\x0820210318\x0820210318\x132021-03-18 12:01:34\x011\x0fCHANG LAI HSIEN\x132021-03-18 10:57:01\x132021-03-18 10:57:14\x02[메리츠화재] 모바일 전자서명 안내\n" & @CRLF & _
"" & @CRLF & _
"4nAjfKqh8i\x0bQUAN CANXIE\n" & @CRLF & _
"" & @CRLF & _
"^[0-9a-zA-Z]{10}\x0b(\([가-힣].*)\n" & @CRLF & _
"^[0-9a-zA-Z]{10}([A-Z가-힣\s]{2,})\\n" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"4nXzVRFyIl\tJIN GUANGMAN\n" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"4nXzVRFyIl\t김현수\n" & @CRLF & _
"" & @CRLF & _
"4nJcIVZHxD\x0b(주)철마\n" & @CRLF & _
"^[0-9a-zA-Z]{10}\\x0b(\\([가-힣].*)\\n" & @CRLF & _
"^[0-9a-zA-Z]{10}\\x0b(\([가-힣].*)\\n" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^[0-9a-zA-Z]{10}\t([A-Z가-힣\s]{2,})\n" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^[0-9a-zA-Z]{10}\\t([A-Z가-힣\s]{2,})\\n" & @CRLF & _
"" & @CRLF & _
"^[0-9a-zA-Z]{10}\t([A-Z가-힣\s]{2,})\n"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")