$re = '/(?:#include ".*?|(?<!^)\G.*?)\KFoo/m';
$str = '#define Foo
#include "abcFoo1/Foo123/aFoo"
int Foo = 69
';
$subst = "Bar";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;