import re
regex = re.compile(r"^0", flags=re.MULTILINE)
test_str = ("0\n"
"1\n"
"2\n"
"3\n"
"4\n"
"5\n"
"6\n"
"7\n")
subst = "1"
result = regex.sub(subst, test_str)
if result:
print(result)