// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z0-9]{3,8}-\d{1}$").unwrap();
let string = "# Genuine values
63638-1
8867-4
55231-5
26464-8
22577-1
# Checking edge cases
12-1
123-1
12345678-9
123456789-9
12345678
12345678-
12345678--
12345678-A
12345678-?
12345678-12
# Adding letters to the main code
LL2435-7
LL358-3
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}