#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[0-9a-zA-Z]*_?){0,2}$"
Local $sString = "sdas__" & @CRLF & _
"sqe1123" & @CRLF & _
"sad123" & @CRLF & _
"jdfo23hb13_" & @CRLF & _
"jdfo23hb13_09kkjkvs_vl_" & @CRLF & _
"jdfo23hb13_09kkjkvs_vl_jdfo23hb13_09kkjkvs_" & @CRLF & _
"jdfo23hb13_09kkjkvs_"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")