using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[0-9a-zA-Z]*_?){0,2}$";
string input = @"sdas__
sqe1123
sad123
jdfo23hb13_
jdfo23hb13_09kkjkvs_vl_
jdfo23hb13_09kkjkvs_vl_jdfo23hb13_09kkjkvs_
jdfo23hb13_09kkjkvs_";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}