#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s+\S+\s+([\dA-Z][A-Z\d\s]+?)\s{2,}"
Local $sString = " EEC001 1EECOL ELECTRIC CORP CANOE PROCUREMENT GROUP " & @CRLF & _
" EEC001 EECOL ELECTRIC CORP CANOE PROCUREMENT GROUP "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")