$re = '@(?<!\d)\d{16}(?!\d)@m';
$str = '1234567812345678
abcbb1234567812345678axaa
123123456781234567812121asaasa
____hbadchc()1234567812345678csdhcbs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);