const regex = /^\/endpoint\/\d+,\d+(?:,\d+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/endpoint\\\/\\d+,\\d+(?:,\\d+)*$', 'gm')
const str = `/endpoint/142,15
/endpoint/142,15,415
/endpoint/142
/endpoint/142,15,985
/endpoint/1,2,3,4
/endpoint/9999,9928,2918,2984,298174
/endpoint/
/endpoint/32,a
/endpoint/1,2,3,4,test
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}