// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/endpoint\/\d+,\d+(?:,\d+)*$").unwrap();
let string = "/endpoint/142,15
/endpoint/142,15,415
/endpoint/142
/endpoint/142,15,985
/endpoint/1,2,3,4
/endpoint/9999,9928,2918,2984,298174
/endpoint/
/endpoint/32,a
/endpoint/1,2,3,4,test
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}