using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"mark";
string input = @"I went to the market so I was marketing.
But it was unremarkable...
I stored my results in the filepath:
/home/adyork/marketsurvey/leftmymark.csv
mark
marketing
unremarkable";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}