$re = '/mark/m';
$str = 'I went to the market so I was marketing.
But it was unremarkable...
I stored my results in the filepath:
/home/adyork/marketsurvey/leftmymark.csv
mark
marketing
unremarkable';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);