package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:var|identifier) (\w+)`)
var str = `var one one
identifier two two`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}