#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((:(?!CID))|;)(.*)"
Local $sString = " 1. (s)[18014]:Recorded command information." & @CRLF & _
" 2. (l):User logged out." & @CRLF & _
" 3. (s)[18014]:CID=0x11aa2222;The user succeeded in logging out of XXX."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")