import re
regex = re.compile(r"((:(?!CID))|;)(.*)", flags=re.MULTILINE)
test_str = (" 1. (s)[18014]:Recorded command information.\n"
" 2. (l):User logged out.\n"
" 3. (s)[18014]:CID=0x11aa2222;The user succeeded in logging out of XXX.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")