const regex = /^P(?:(?P<years>[0-9\.]+)Y)?(?:(?P<months>[0-9\.]+)M)?(?:(?P<days>[0-9\.]+)D)?(?P<time>T(?:(?P<hours>[0-9\.]+)H)?(?:(?P<minutes>[0-9\.]+)M)?(?:(?P<seconds>[0-9\.]+)S)?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^P(?:(?P<years>[0-9\\.]+)Y)?(?:(?P<months>[0-9\\.]+)M)?(?:(?P<days>[0-9\\.]+)D)?(?P<time>T(?:(?P<hours>[0-9\\.]+)H)?(?:(?P<minutes>[0-9\\.]+)M)?(?:(?P<seconds>[0-9\\.]+)S)?)?$', 'gm')
const str = `P1Y2M3DT4H5M6.007S
PT12H
PT12.007S`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);