use strict;
my $str = 'Test123éËà-ŞŨğБла通用';
my $regex = qr`\P{L}`mp;
my $subst = '';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";