const regex = /(?:^mem:|\G(?!^))\s+\K\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^mem:|\\G(?!^))\\s+\\K\\d+', 'gm')
const str = `mem: 9 334 23423343 3433434`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}