$re = '/(?:^mem:|\G(?!^))\s+\K\d+/m';
$str = 'mem: 9 334 23423343 3433434';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);