#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)\#+ \K" & @CRLF & _
"(?: (?<five> \d+) , )??" & @CRLF & _
"(?: (?<four> \d+) , )??" & @CRLF & _
"(?: (?<three> \d+) , )??" & @CRLF & _
"(?: (?<two> \d+) , )?" & @CRLF & _
"(?<one>\d+)" & @CRLF & _
"(?!\S)"
Local $sString = "~~~~~~~~#5,4,3,2,1" & @CRLF & _
"~~~~~~~##4,3,2,1" & @CRLF & _
"~~~~~~###3,2,1" & @CRLF & _
"~~~~~####2,1" & @CRLF & _
"~~~~#####1 >))))))°>" & @CRLF & _
"~~~~~####2,1" & @CRLF & _
"~~~~~~###3,2,1" & @CRLF & _
"~~~~~~~##4,3,2,1" & @CRLF & _
"~~~~~~~~#5,4,3,2,1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")