# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(NICA)* *BOX +#? *[0-9]{4}$/\4/g;t' <<< "NICA BOX #1122"