#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(NICA)* *BOX +#? *[0-9]{4}$"
Local $sString = "NICA BOX #1122"
Local $sSubst = "\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)