use strict;
my $str = 'NICA BOX #1122';
my $regex = qr/^(NICA)* *BOX +#? *[0-9]{4}$/p;
my $subst = '\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";