// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(NICA)* *BOX +#? *[0-9]{4}$").unwrap();
let string = "NICA BOX #1122";
let substitution = "\\4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}