re = /(?i)\S*[a-z].+[a-z0-9]/m
str = '.. -- Água, 1234 ...
- -- https://www.example.com/page.html *****'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end