// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)\S*[a-z].+[a-z0-9]").unwrap();
let string = ".. -- Água, 1234 ...
- -- https://www.example.com/page.html *****";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}