#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[ab]|ab)(.)(?:(?!\1).)+\1$"
Local $sString = "It is pattern against free delimiter" & @CRLF & _
"" & @CRLF & _
"ab some-word " & @CRLF & _
"" & @CRLF & _
"a some-word " & @CRLF & _
"" & @CRLF & _
"b|some-word|" & @CRLF & _
"" & @CRLF & _
"ab#some-word#" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")