using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[ab]|ab)(.)(?:(?!\1).)+\1$";
string input = @"It is pattern against free delimiter
ab some-word
a some-word
b|some-word|
ab#some-word#
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}