$re = '/(\w+\.\w+).*$/m';
$str = 'x=>x.ab
x=> x.ab
x => x.ab
x =>x.ab
x =>{return x.ab}
x => {return x.ab;}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);