#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\<IpAddress\>(?<IP>\d+\.\d+\.\d+\.\d+)"
Local $sString = " <IpAddress>8.8.8.8, 2.2.2.2</IpAddress>" & @CRLF & _
" <blahblah>1.1.1.1, 2.2.2.2, x.x.x.x</blahblah>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")