#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(XXS\/XS|XS\/S|S\/M|M\/L|L\/XL|XL\/XXL|XXS|XS|S|M|L|XL|XXL|\d{2}\.\d{1}|\d{2}|youth)"
Local $sString = "XXS/XS - 27.5"" & @CRLF & _
"XS/S - 27.5"" & @CRLF & _
"S/M - 27.5"" & @CRLF & _
"M/L - 27.5"" & @CRLF & _
"M/L - 29"" & @CRLF & _
"L/XL - 27.5"" & @CRLF & _
"L/XL - 29"" & @CRLF & _
"XL/XXL - 29"" & @CRLF & _
"S" & @CRLF & _
"M" & @CRLF & _
"L" & @CRLF & _
"XL" & @CRLF & _
"XXL" & @CRLF & _
"XXS - 27.5"" & @CRLF & _
"XS - 27.5"" & @CRLF & _
"S - 27.5"" & @CRLF & _
"S - 29"" & @CRLF & _
"M - 27.5"" & @CRLF & _
"M - 29"" & @CRLF & _
"L - 29"" & @CRLF & _
"XL - 29"" & @CRLF & _
"45.5 - 650B" & @CRLF & _
"48 - 650B" & @CRLF & _
"50.5 - 700c" & @CRLF & _
"53 - 700c" & @CRLF & _
"55.5 - 700c" & @CRLF & _
"58 - 700c" & @CRLF & _
"60.5 - 700c" & @CRLF & _
"45.5" & @CRLF & _
"48" & @CRLF & _
"50.5" & @CRLF & _
"53" & @CRLF & _
"55.5" & @CRLF & _
"58" & @CRLF & _
"60.5" & @CRLF & _
"youth"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")