const regex = /\b(\d+)\1+\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d+)\\1+\\b', 'gmi')
const str = `11111111, 2222, 99999999999,123123123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}