import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=((?<=[\\s,.:;\"']|^)[\"']))(?:(?=(\\\\?))\\2.)*?(?=\\1)";
final String string = "Hello world \"This is a test\"\n"
+ "\"This is also an NL test\"\n"
+ "'And this has an escaped quote don\\'t in it ' Blue Boy\n"
+ "\"This has a single quote ' but doesn\\' end the quote as it started with double quotes\"\n\n"
+ "\" Lorem ipsum dolor\\\" sit 'amet' \"\n\n"
+ "\"你好\" \"こんにちは\" \"Привет\" \"हैलो\"\n"
+ "\"Foo Bar\" \"Another Value\" \"HELLO WORLD\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}