package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) +$`)
var str = `n = 10
for i in range(n):
print(i) `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}