using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*\d+(?:\s*,\s*\d+)*\s*$";
string input = @"1 , 8,9, 88
8 , 44, 3 , 11
1,2,3,4
1 , 2,3,9
8 , 44, 3 , 11
1
1,2
1,2
1 ,2
1 2, 5
1, 2,
, 1,2,
1,2 3,4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}