use strict;
my $str = '1 , 8,9, 88
8 , 44, 3 , 11
1,2,3,4
1 , 2,3,9
8 , 44, 3 , 11
1
1,2
1,2
1 ,2
1 2, 5
1, 2,
, 1,2,
1,2 3,4';
my $regex = qr/^\s*\d+(?:\s*,\s*\d+)*\s*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}