using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([#@\s]|:[)(])|\W";
string substitution = @"\1";
string input = @"this is, a placeholder text. I wanna remove symbols like ! and ? but keep @ & # & :)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}