$re = '/<\s*\/\s*div\s*.*?>/';
$str = '<div class="sds">javascript + CSS ...</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);