#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "rgba\([^$]"
Local $sString = "box-shadow: 0 0 3px 1px rgba(black, 0.2);" & @CRLF & _
"-webkit-box-shadow: 0 0 10px 0 rgba($black, 0.07);" & @CRLF & _
"background: rgba(236, 236, 236, 0.8);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")