using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"rgba\([^$]";
string input = @"box-shadow: 0 0 3px 1px rgba(black, 0.2);
-webkit-box-shadow: 0 0 10px 0 rgba($black, 0.07);
background: rgba(236, 236, 236, 0.8);";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}