#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\W|^)(alineas|alinea|alis\.?|ali\.?) (?:([a-z])|\"([a-z])\")(?:\W|$)"
Local $sString = "alinea a," & @CRLF & _
"alinea "a"," & @CRLF & _
"ali. "a"," & @CRLF & _
"ali "a"," & @CRLF & _
"ali. a," & @CRLF & _
"ali. "a"," & @CRLF & _
"ali. a"," & @CRLF & _
"ali a" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")