package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\W|^)(alineas|alinea|alis\.?|ali\.?) (?:([a-z])|\"([a-z])\")(?:\W|$)`)
var str = `alinea a,
alinea "a",
ali. "a",
ali "a",
ali. a,
ali. "a",
ali. a",
ali a
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}