re = /\bBuilding[\s:]+(\d+(?:\.\d+)?)\b/m
str = 'Building 38 House 10
Building : 10.5 house 900'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end