import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(E)(?=\\d{4})";
final String string = "Test String\n"
+ "2571130,733 5533151,436 E5015 6 16 E5015 16 \n"
+ "2576626,674 5531614,498 E5090 6 16 E50900 16 \n"
+ "2576614,102 5531577,319 E50/17 1 16 E50/17 16 \n"
+ "2567054,088 5538296,751 E5018 6 16 ;E5018 16 \n"
+ "2576606,227 5531589,142 E5070 6 16 Ei5070 16 \n"
+ "2584724,341 5502054,434 R7070 6 17 F7070 16 \n"
+ "2584735,918 5502107,131 R7014 6 17 R7014 16";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}