# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<script)((?:(?!src=).)*?>)/$1 nonce="$cspNonce"$2/g;t' <<< "<script>console.log(\"Jareté!\");</script>
<script type=\"text/javascript\">console.log('Hola!');</script>
<script type=\"text/javascript\">console.log(\"Jaguereté!\");</script>
<script type=\"text/javascript\" src=\"whatever.js\">console.log(\"Jaguereté!\");</script>
<script type=\"text/javascript\" src=\"whatever.js\">console.log(\"Jaguereté!\");</script> "