import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=[-\\w]{2}).*";
final String string = "ABD\n"
+ "Abc_123\n"
+ "12\n"
+ "A-_\n"
+ "A1\n"
+ "A\n"
+ "1\n"
+ "--\n"
+ "__";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}