$re = '/(?=[-\w]{2}).*/';
$str = 'ABD
Abc_123
12
A-_
A1
A
1
--
__';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);